ports/net/freerdp/files/patch-cmake_InstallFreeRDPMan.cmake
Vladimir Druzenko 8d656131d2 net/freerdp: sort out port
1. Move manpages from LOCALBASE/man/ to LOCALBASE/share/man/.
2. Update ARM NEON support (details are at https://reviews.freebsd.org/D43127).
3. Unification of the pkg-plist with upcoming net/freerdp3: replace "2" with "%%MAJORVERSION%%".

Approved by:		arrowd (mentor)
Differential Revision:	https://reviews.freebsd.org/D43352
2024-01-07 01:22:55 +03:00

10 lines
392 B
CMake

--- cmake/InstallFreeRDPMan.cmake.orig 2023-12-14 18:03:49 UTC
+++ cmake/InstallFreeRDPMan.cmake
@@ -1,6 +1,6 @@
function(install_freerdp_man manpage section)
if(WITH_MANPAGES)
- if(OPENBSD OR FREEBSD)
+ if(OPENBSD)
install(FILES ${manpage} DESTINATION man/man${section})
else()
install(FILES ${manpage} DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/man/man${section})