mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
ES-DE (formerly known as EmulationStation Desktop Edition) is a frontend for browsing and launching games from your multi-platform collection. It comes preconfigured for use with a large selection of emulators, game engines, game managers and gaming services. It can also run locally installed games and applications. It's fully customizable, so you can easily expand it with support for additional systems and applications. It features a modern and attractive user interface, full controller navigation support, supports over 150 different game systems, highly customizable setup, a built-in scraper for downloading game info and game media, full theme support with lots of high-quality themes. https://es-de.org https://gitlab.com/es-de/emulationstation-de PR: 280891
23 lines
721 B
Text
23 lines
721 B
Text
--- external/CMakeLists.txt.orig 2024-06-14 15:36:56 UTC
|
|
+++ external/CMakeLists.txt
|
|
@@ -61,13 +61,9 @@ endif()
|
|
set(CMAKE_CXX_FLAGS -pthread)
|
|
endif()
|
|
|
|
-add_subdirectory(rlottie EXCLUDE_FROM_ALL)
|
|
-
|
|
# rlottie generates a lot of annoying compiler warnings that we don't need to show.
|
|
if(CMAKE_CXX_COMPILER_ID MATCHES MSVC)
|
|
target_compile_options(rlottie PRIVATE "/wd4244" "/wd4251" "/wd4263" "/wd4334" "/wd4267" "/wd4530" "/wd4996")
|
|
-else()
|
|
- target_compile_options(rlottie PRIVATE "-w")
|
|
endif()
|
|
|
|
if(ANDROID)
|
|
@@ -79,6 +75,3 @@ endif()
|
|
${PROJECT_SOURCE_DIR}/android_${ANDROID_ABI})
|
|
endif()
|
|
endif()
|
|
-
|
|
-# Build LunaSVG before rlottie.
|
|
-add_dependencies(rlottie lunasvg)
|