mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Mk/Uses/gstreamer.mk: - Sort, fix whitespace issues and typos - Promote several common variables to improve maintainer QOL * There's now no need to set manually set PORTVERSION nor SOVERSION in several Makefiles * This will help to prevent not updating some components * A note has been added, however, to remind maintainers to remake distinfo for certain ports - Improve documentation multimedia/gstreamer1-plugins-webrtc: - New port split from multimedia/gstreamer1-plugins-bad - multimedia/gstreamer1-plugins-rust has been updated to reflect this change net/gstreamer1-plugins-sctp: - New port split from multimedia/gstreamer1-plugins-bad x11-toolkits/gstreamer1-plugins-qt5: - Moved here from graphics/gstreamer1-plugins-qt to align with its new Qt6 counterpart x11-toolkits/gstreamer1-plugins-qt6: - New port: GStreamer Qt6 QML videosink plugin */*: - Improve Makefile order and formatting - Sorry for the repo churn, but not fixing this would just lead to more poorly formatted gstreamer ports in the future via copypasta https://gstreamer.freedesktop.org/releases/1.24/#1.24.8 PR: 278914 Reported by: vvd
22 lines
632 B
Text
22 lines
632 B
Text
--- tools/meson.build.orig 2024-08-21 11:25:15 UTC
|
|
+++ tools/meson.build
|
|
@@ -1,3 +1,4 @@
|
|
+if not get_option('tools').disabled() and not static_build
|
|
gst_tools = {
|
|
'gst-transcoder': {
|
|
'files': files('gst-transcoder.c', 'utils.c'),
|
|
@@ -5,7 +6,6 @@ gst_tools = {
|
|
},
|
|
}
|
|
|
|
-if not get_option('tools').disabled() and not static_build
|
|
foreach tool, data: gst_tools
|
|
exe_name = '@0@-@1@'.format(tool, api_version)
|
|
executable(exe_name,
|
|
@@ -21,4 +21,4 @@ if not get_option('tools').disabled() and not static_b
|
|
install_man(data.get('man_page'))
|
|
endif
|
|
endforeach
|
|
-endif
|
|
\ No newline at end of file
|
|
+endif
|