mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
Mk/Uses/gstreamer.mk: - Sort, fix whitespace issues and typos - Promote several common variables to improve maintainer QOL * There's now no need to set manually set PORTVERSION nor SOVERSION in several Makefiles * This will help to prevent not updating some components * A note has been added, however, to remind maintainers to remake distinfo for certain ports - Improve documentation multimedia/gstreamer1-plugins-webrtc: - New port split from multimedia/gstreamer1-plugins-bad - multimedia/gstreamer1-plugins-rust has been updated to reflect this change net/gstreamer1-plugins-sctp: - New port split from multimedia/gstreamer1-plugins-bad x11-toolkits/gstreamer1-plugins-qt5: - Moved here from graphics/gstreamer1-plugins-qt to align with its new Qt6 counterpart x11-toolkits/gstreamer1-plugins-qt6: - New port: GStreamer Qt6 QML videosink plugin */*: - Improve Makefile order and formatting - Sorry for the repo churn, but not fixing this would just lead to more poorly formatted gstreamer ports in the future via copypasta https://gstreamer.freedesktop.org/releases/1.24/#1.24.8 PR: 278914 Reported by: vvd
26 lines
847 B
Text
26 lines
847 B
Text
--- gst-libs/gst/va/meson.build.orig 2024-09-19 10:01:21 UTC
|
|
+++ gst-libs/gst/va/meson.build
|
|
@@ -45,12 +45,12 @@ extra_args = ['-DGST_USE_UNSTABLE_API',
|
|
'-DBUILDING_GST_VA',
|
|
'-DG_LOG_DOMAIN="GStreamer-VA"']
|
|
|
|
-if host_system not in ['linux', 'windows']
|
|
+if get_option('skip_gstva')
|
|
subdir_done()
|
|
endif
|
|
|
|
va_opt = get_option('va')
|
|
-if host_system == 'linux'
|
|
+if host_system in ['linux', 'freebsd']
|
|
msdk_opt = get_option('msdk')
|
|
qsv_opt = get_option('qsv')
|
|
if va_opt.disabled() and msdk_opt.disabled() and qsv_opt.disabled()
|
|
@@ -75,7 +75,7 @@ endif
|
|
subdir_done()
|
|
endif
|
|
|
|
-if host_system == 'linux'
|
|
+if host_system in ['linux', 'freebsd']
|
|
libva_drm_dep = dependency('libva-drm', version: libva_req, required: va_required,
|
|
fallback: ['libva', 'libva_drm_dep'])
|
|
if not libva_drm_dep.found()
|