ports/multimedia/gstreamer1-plugins-bad/files/patch-gst-libs_gst_mpegts_meson.build
Jason E. Hale 8c1efc578d multimedia/gstreamer1: Update to 1.24.8
Mk/Uses/gstreamer.mk:
- Sort, fix whitespace issues and typos
- Promote several common variables to improve maintainer QOL
*   There's now no need to set manually set PORTVERSION nor
    SOVERSION in several Makefiles
*   This will help to prevent not updating some components
*   A note has been added, however, to remind maintainers
    to remake distinfo for certain ports
- Improve documentation

multimedia/gstreamer1-plugins-webrtc:
- New port split from multimedia/gstreamer1-plugins-bad
- multimedia/gstreamer1-plugins-rust has been updated
  to reflect this change

net/gstreamer1-plugins-sctp:
- New port split from multimedia/gstreamer1-plugins-bad

x11-toolkits/gstreamer1-plugins-qt5:
- Moved here from graphics/gstreamer1-plugins-qt to
  align with its new Qt6 counterpart

x11-toolkits/gstreamer1-plugins-qt6:
- New port: GStreamer Qt6 QML videosink plugin

*/*:
- Improve Makefile order and formatting
- Sorry for the repo churn, but not fixing this would just lead to more
  poorly formatted gstreamer ports in the future via copypasta

https://gstreamer.freedesktop.org/releases/1.24/#1.24.8

PR:		278914
Reported by:	vvd
2024-09-22 06:35:56 -04:00

12 lines
400 B
Text

--- gst-libs/gst/mpegts/meson.build.orig 2024-08-21 11:25:15 UTC
+++ gst-libs/gst/mpegts/meson.build
@@ -1,3 +1,4 @@
+if get_option('mpegts').enabled()
mpegts_sources = files(
'mpegts.c',
'gstmpegtssection.c',
@@ -87,3 +88,4 @@ meson.override_dependency(pkg_name, gstmpegts_dep)
dependencies : [gst_dep],
sources : gen_sources)
meson.override_dependency(pkg_name, gstmpegts_dep)
+endif