mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Mk/Uses/gstreamer.mk: - Sort, fix whitespace issues and typos - Promote several common variables to improve maintainer QOL * There's now no need to set manually set PORTVERSION nor SOVERSION in several Makefiles * This will help to prevent not updating some components * A note has been added, however, to remind maintainers to remake distinfo for certain ports - Improve documentation multimedia/gstreamer1-plugins-webrtc: - New port split from multimedia/gstreamer1-plugins-bad - multimedia/gstreamer1-plugins-rust has been updated to reflect this change net/gstreamer1-plugins-sctp: - New port split from multimedia/gstreamer1-plugins-bad x11-toolkits/gstreamer1-plugins-qt5: - Moved here from graphics/gstreamer1-plugins-qt to align with its new Qt6 counterpart x11-toolkits/gstreamer1-plugins-qt6: - New port: GStreamer Qt6 QML videosink plugin */*: - Improve Makefile order and formatting - Sorry for the repo churn, but not fixing this would just lead to more poorly formatted gstreamer ports in the future via copypasta https://gstreamer.freedesktop.org/releases/1.24/#1.24.8 PR: 278914 Reported by: vvd
26 lines
817 B
Text
26 lines
817 B
Text
--- gst-libs/gst/codecs/meson.build.orig 2024-08-21 11:25:15 UTC
|
|
+++ gst-libs/gst/codecs/meson.build
|
|
@@ -1,3 +1,4 @@
|
|
+if get_option('codecs').enabled()
|
|
codecs_sources = files(
|
|
'gsth264decoder.c',
|
|
'gsth264picture.c',
|
|
@@ -51,6 +52,13 @@ pkg_name = 'gstreamer-codecs-1.0'
|
|
|
|
library_def = {'lib': gstcodecs}
|
|
pkg_name = 'gstreamer-codecs-1.0'
|
|
+pkgconfig.generate(gstcodecs,
|
|
+ libraries : [gst_dep, gstbase_dep],
|
|
+ variables : pkgconfig_variables,
|
|
+ subdirs : pkgconfig_subdirs,
|
|
+ name : pkg_name,
|
|
+ description : 'Codecs library for GStreamer elements',
|
|
+)
|
|
gen_sources = []
|
|
if build_gir
|
|
gir = {
|
|
@@ -85,3 +93,4 @@ meson.override_dependency(pkg_name, gstcodecs_dep)
|
|
sources: gen_sources,
|
|
dependencies : [gstvideo_dep, gstcodecparsers_dep])
|
|
meson.override_dependency(pkg_name, gstcodecs_dep)
|
|
+endif
|