mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Mk/Uses/gstreamer.mk: - Sort, fix whitespace issues and typos - Promote several common variables to improve maintainer QOL * There's now no need to set manually set PORTVERSION nor SOVERSION in several Makefiles * This will help to prevent not updating some components * A note has been added, however, to remind maintainers to remake distinfo for certain ports - Improve documentation multimedia/gstreamer1-plugins-webrtc: - New port split from multimedia/gstreamer1-plugins-bad - multimedia/gstreamer1-plugins-rust has been updated to reflect this change net/gstreamer1-plugins-sctp: - New port split from multimedia/gstreamer1-plugins-bad x11-toolkits/gstreamer1-plugins-qt5: - Moved here from graphics/gstreamer1-plugins-qt to align with its new Qt6 counterpart x11-toolkits/gstreamer1-plugins-qt6: - New port: GStreamer Qt6 QML videosink plugin */*: - Improve Makefile order and formatting - Sorry for the repo churn, but not fixing this would just lead to more poorly formatted gstreamer ports in the future via copypasta https://gstreamer.freedesktop.org/releases/1.24/#1.24.8 PR: 278914 Reported by: vvd
12 lines
590 B
Text
12 lines
590 B
Text
--- gst-libs/gst/audio/meson.build.orig 2024-08-21 11:25:15 UTC
|
|
+++ gst-libs/gst/audio/meson.build
|
|
@@ -1,3 +1,4 @@
|
|
+if get_option('audio').enabled()
|
|
badaudio_sources = files('gstnonstreamaudiodecoder.c', 'gstplanaraudioadapter.c')
|
|
badaudio_headers = files('gstnonstreamaudiodecoder.h', 'audio-bad-prelude.h', 'gstplanaraudioadapter.h')
|
|
install_headers(badaudio_headers, subdir : 'gstreamer-1.0/gst/audio')
|
|
@@ -53,3 +54,4 @@ meson.override_dependency(pkg_name, gstbadaudio_dep)
|
|
dependencies : [gstaudio_dep, gstbase_dep])
|
|
|
|
meson.override_dependency(pkg_name, gstbadaudio_dep)
|
|
+endif
|