ports/multimedia/gstreamer1-plugins-bad/files/patch-ext_webrtc_meson.build
Jason E. Hale 8c1efc578d multimedia/gstreamer1: Update to 1.24.8
Mk/Uses/gstreamer.mk:
- Sort, fix whitespace issues and typos
- Promote several common variables to improve maintainer QOL
*   There's now no need to set manually set PORTVERSION nor
    SOVERSION in several Makefiles
*   This will help to prevent not updating some components
*   A note has been added, however, to remind maintainers
    to remake distinfo for certain ports
- Improve documentation

multimedia/gstreamer1-plugins-webrtc:
- New port split from multimedia/gstreamer1-plugins-bad
- multimedia/gstreamer1-plugins-rust has been updated
  to reflect this change

net/gstreamer1-plugins-sctp:
- New port split from multimedia/gstreamer1-plugins-bad

x11-toolkits/gstreamer1-plugins-qt5:
- Moved here from graphics/gstreamer1-plugins-qt to
  align with its new Qt6 counterpart

x11-toolkits/gstreamer1-plugins-qt6:
- New port: GStreamer Qt6 QML videosink plugin

*/*:
- Improve Makefile order and formatting
- Sorry for the repo churn, but not fixing this would just lead to more
  poorly formatted gstreamer ports in the future via copypasta

https://gstreamer.freedesktop.org/releases/1.24/#1.24.8

PR:		278914
Reported by:	vvd
2024-09-22 06:35:56 -04:00

34 lines
1.1 KiB
Text

--- ext/webrtc/meson.build.orig 2024-08-21 11:25:15 UTC
+++ ext/webrtc/meson.build
@@ -1,3 +1,4 @@
+if get_option('webrtc').enabled()
webrtc_sources = [
'gstwebrtc.c',
'gstwebrtcstats.c',
@@ -12,6 +13,14 @@ webrtc_sources = [
'webrtcdatachannel.c',
]
+if not is_variable('libgstwebrtcnice_dep')
+ subdir_done()
+endif
+
+if not is_variable('gstsctp_dep')
+ gstsctp_dep=cc.find_library('gstsctp-1.0', required : true)
+endif
+
webrtc_option = get_option('webrtc').require(
libgstwebrtcnice_dep.found(), error_message: 'webrtc plugin requires libgstwebrtcnice.')
if webrtc_option.disabled()
@@ -23,9 +32,9 @@ gstwebrtc_plugin = library('gstwebrtc',
c_args : gst_plugins_bad_args + ['-DGST_USE_UNSTABLE_API'],
include_directories : [configinc],
dependencies : [gstbase_dep, gstsdp_dep,
- gstapp_dep, gstwebrtc_dep, gstsctp_dep, gstrtp_dep, gio_dep, libgstwebrtcnice_dep],
+ gstapp_dep, gstwebrtc_dep, dependency('gstreamer-sctp-1.0'), gstrtp_dep, gio_dep, libgstwebrtcnice_dep],
install : true,
install_dir : plugins_install_dir,
)
plugins += [gstwebrtc_plugin]
-
+endif