mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Mk/Uses/gstreamer.mk: - Sort, fix whitespace issues and typos - Promote several common variables to improve maintainer QOL * There's now no need to set manually set PORTVERSION nor SOVERSION in several Makefiles * This will help to prevent not updating some components * A note has been added, however, to remind maintainers to remake distinfo for certain ports - Improve documentation multimedia/gstreamer1-plugins-webrtc: - New port split from multimedia/gstreamer1-plugins-bad - multimedia/gstreamer1-plugins-rust has been updated to reflect this change net/gstreamer1-plugins-sctp: - New port split from multimedia/gstreamer1-plugins-bad x11-toolkits/gstreamer1-plugins-qt5: - Moved here from graphics/gstreamer1-plugins-qt to align with its new Qt6 counterpart x11-toolkits/gstreamer1-plugins-qt6: - New port: GStreamer Qt6 QML videosink plugin */*: - Improve Makefile order and formatting - Sorry for the repo churn, but not fixing this would just lead to more poorly formatted gstreamer ports in the future via copypasta https://gstreamer.freedesktop.org/releases/1.24/#1.24.8 PR: 278914 Reported by: vvd
11 lines
471 B
Text
11 lines
471 B
Text
--- ext/vulkan/meson.build.orig 2024-08-21 11:25:15 UTC
|
|
+++ ext/vulkan/meson.build
|
|
@@ -37,7 +37,7 @@ if vulkan_conf.get('GST_VULKAN_HAVE_VIDEO_EXTENSIONS')
|
|
extra_args = []
|
|
if vulkan_conf.get('GST_VULKAN_HAVE_VIDEO_EXTENSIONS') == 1
|
|
vulkan_sources += files('vkh264dec.c', 'vkh265dec.c')
|
|
- extra_deps += gstcodecs_dep
|
|
+ extra_deps += [dependency('gstreamer-codecparsers-1.0'), dependency('gstreamer-codecs-1.0')]
|
|
extra_args += ['-DGST_USE_UNSTABLE_API']
|
|
endif
|
|
|