mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Mk/Uses/gstreamer.mk: - Sort, fix whitespace issues and typos - Promote several common variables to improve maintainer QOL * There's now no need to set manually set PORTVERSION nor SOVERSION in several Makefiles * This will help to prevent not updating some components * A note has been added, however, to remind maintainers to remake distinfo for certain ports - Improve documentation multimedia/gstreamer1-plugins-webrtc: - New port split from multimedia/gstreamer1-plugins-bad - multimedia/gstreamer1-plugins-rust has been updated to reflect this change net/gstreamer1-plugins-sctp: - New port split from multimedia/gstreamer1-plugins-bad x11-toolkits/gstreamer1-plugins-qt5: - Moved here from graphics/gstreamer1-plugins-qt to align with its new Qt6 counterpart x11-toolkits/gstreamer1-plugins-qt6: - New port: GStreamer Qt6 QML videosink plugin */*: - Improve Makefile order and formatting - Sorry for the repo churn, but not fixing this would just lead to more poorly formatted gstreamer ports in the future via copypasta https://gstreamer.freedesktop.org/releases/1.24/#1.24.8 PR: 278914 Reported by: vvd
11 lines
377 B
Text
11 lines
377 B
Text
--- ext/srtp/meson.build.orig 2024-08-21 11:25:15 UTC
|
|
+++ ext/srtp/meson.build
|
|
@@ -7,7 +7,7 @@ srtp_cargs = []
|
|
]
|
|
|
|
srtp_cargs = []
|
|
-srtp_option = get_option('srtp').enable_if(get_option('webrtc').enabled(), error_message: 'webrtc option is enabled')
|
|
+srtp_option = get_option('srtp')
|
|
if srtp_option.disabled()
|
|
srtp_dep = dependency('', required : false)
|
|
subdir_done()
|