ports/www/qt5-webengine/files/patch-src_3rdparty_chromium_v8_BUILD.gn
Kai Knoblich 8067206f03 www/qt5-webengine: Update to 5.15.8
* Under the hood runs Chromium 87.0.4280.144 with security fixes up to
  version 96.0.4664.110 and patches were taken from of www/chromium
  87.0.4280.141 (391acded85).

* Prune some unneeded patches (mostly from the headless and unittest
  areas) and try to align the unbundling of dependencies similar to
  qt6-webengine for consistency.

* Adjust Mk/Uses/qt-dist.mk accordingly as the naming of the distfiles
  has changed since Qt 5.15.3.

Tested by:	tcberner
Differential Revision:	https://reviews.freebsd.org/D38165
2023-03-06 05:33:32 +01:00

27 lines
758 B
Text

--- src/3rdparty/chromium/v8/BUILD.gn.orig 2021-12-15 16:12:54 UTC
+++ src/3rdparty/chromium/v8/BUILD.gn
@@ -4116,9 +4116,15 @@ v8_component("v8_libbase") {
}
}
- if (is_linux || is_chromeos) {
+ if (is_bsd) {
sources += [
"src/base/debug/stack_trace_posix.cc",
+ "src/base/platform/platform-freebsd.cc",
+ ]
+ libs = [ "rt", "execinfo" ]
+ } else if (is_linux || is_chromeos) {
+ sources += [
+ "src/base/debug/stack_trace_posix.cc",
"src/base/platform/platform-linux.cc",
]
@@ -4524,6 +4530,7 @@ if (current_toolchain == v8_generator_toolchain) {
"src/interpreter/bytecodes.cc",
"src/interpreter/bytecodes.h",
]
+ libs = ["execinfo"]
configs = [ ":internal_config" ]