mirror of
https://git.freebsd.org/ports.git
synced 2025-05-29 01:16:28 -04:00
PR: ports/174660 Submitted by: Alexandr Kovalenko <never@nevermind.kiev.ua> Approved by: geoffroy desvernay <dgeo@centrale-marseille.fr> (maintainer of databases/mariadb-*)
36 lines
1.2 KiB
Text
36 lines
1.2 KiB
Text
--- libmysql/CMakeLists.txt.orig 2010-12-03 18:58:26.000000000 +0100
|
|
+++ libmysql/CMakeLists.txt 2010-12-23 22:01:37.000000000 +0100
|
|
@@ -153,13 +153,14 @@
|
|
|
|
# Merge several convenience libraries into one big mysqlclient
|
|
# and link them together into shared library.
|
|
-MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development)
|
|
+MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development NOINSTALL)
|
|
|
|
# Visual Studio users need debug static library for debug projects
|
|
IF(MSVC)
|
|
INSTALL_DEBUG_TARGET(mysqlclient DESTINATION ${INSTALL_LIBDIR}/debug)
|
|
ENDIF()
|
|
|
|
+IF(FALSE)
|
|
IF(UNIX)
|
|
MACRO(GET_VERSIONED_LIBNAME LIBNAME EXTENSION VERSION OUTNAME)
|
|
SET(DOT_VERSION ".${VERSION}")
|
|
@@ -174,9 +175,11 @@
|
|
ENDMACRO()
|
|
INSTALL_SYMLINK(${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a mysqlclient ${INSTALL_LIBDIR} Development)
|
|
ENDIF()
|
|
+ENDIF()
|
|
|
|
IF(NOT DISABLE_SHARED)
|
|
- MERGE_LIBRARIES(libmysql SHARED ${LIBS} EXPORTS ${CLIENT_API_FUNCTIONS} COMPONENT SharedLibraries)
|
|
+ MERGE_LIBRARIES(libmysql SHARED ${LIBS} EXPORTS ${CLIENT_API_FUNCTIONS} COMPONENT SharedLibraries NOINSTALL)
|
|
+IF(FALSE)
|
|
IF(UNIX)
|
|
# libtool compatability
|
|
IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE)
|
|
@@ -223,3 +226,4 @@
|
|
ENDFOREACH()
|
|
ENDIF()
|
|
ENDIF()
|
|
+ENDIF()
|