mirror of
https://git.freebsd.org/ports.git
synced 2025-05-04 07:27:38 -04:00
- Bump PORTREVISION for package change Upstream builds this port with sphinx-theme-builder. However, it does not work on FreeBSD yet since the nodeenv would try to download pre-built node.js binary executable which is unavailable for FreeBSD. Therefore, I use flit-core with pre-built static files instead.
20 lines
531 B
TOML
20 lines
531 B
TOML
--- pyproject.toml.orig 2024-07-24 09:09:51 UTC
|
|
+++ pyproject.toml
|
|
@@ -1,6 +1,6 @@
|
|
[build-system]
|
|
-requires = ["sphinx-theme-builder >= 0.2.0a10"]
|
|
-build-backend = "sphinx_theme_builder"
|
|
+requires = ["flit-core >= 3.9.0"]
|
|
+build-backend = "flit_core.buildapi"
|
|
|
|
[tool.sphinx-theme-builder]
|
|
node-version = "18.16.0"
|
|
@@ -15,7 +15,7 @@ dependencies = [
|
|
requires-python = ">=3.8"
|
|
dependencies = [
|
|
"beautifulsoup4",
|
|
- "sphinx >= 6.0,<9.0",
|
|
+ "sphinx >= 5.0,<9.0",
|
|
"sphinx-basic-ng >= 1.0.0.beta2",
|
|
"pygments >= 2.7",
|
|
]
|