ports/multimedia/ffmpeg/files/patch-configure
Jan Beich 84e727457f multimedia/ffmpeg: update to 3.4
Notable changes:
- i386/amd64 now depend on NASM per https://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff/4f9297ac3b39
- NETCDF is now MYSOFA but the dependency doesn't exist in ports yet
- SCHROEDINGER is gone per https://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff/220b24c7c9
- DRM, LIBRSVG2, LIBXML2 are new options
- ABI isn't completely compatible: some structs have changed

Minor cleanup:
- Don't pass --disable-{in,out}dev when it's already blocked by disabled dependency
- Drop redundant "Enable" from option descriptions
- Switch CDIO_DESC to use Mk/bsd.options.desc.mk

Changes:	https://git.ffmpeg.org/gitweb/ffmpeg.git/blob/n3.4:/Changelog
ABI:		https://abi-laboratory.pro/tracker/timeline/ffmpeg/
PR:		223057
Exp-run by:	antoine
2017-10-21 06:50:49 +00:00

26 lines
743 B
Text

--- configure.orig 2017-10-15 15:59:36 UTC
+++ configure
@@ -3371,12 +3371,7 @@ target_os_default=$(tolower $(uname -s))
host_os=$target_os_default
# machine
-if test "$target_os_default" = aix; then
- arch_default=$(uname -p)
- strip_default="strip -X32_64"
-else
- arch_default=$(uname -m)
-fi
+arch_default=$(uname -p)
cpu="generic"
intrinsics="none"
@@ -6491,6 +6486,9 @@ elif enabled llvm_gcc; then
elif enabled clang; then
check_cflags -mllvm -stack-alignment=16
check_cflags -mstack-alignment=16
+ if enabled x86_32; then
+ check_cflags -mstackrealign
+ fi
check_cflags -Qunused-arguments
check_cflags -Werror=implicit-function-declaration
check_cflags -Werror=missing-prototypes