mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Changelog: https://gitlab.linphone.org/BC/public/liblinphone/-/tags/5.4.4 Sponsored by: Cybermancer Infosec
26 lines
962 B
Text
26 lines
962 B
Text
Fix compilation error:
|
|
|
|
src/core/core.cpp:428:2: error: void function 'doLater' should not return a
|
|
value [-Wreturn-type]
|
|
--- CMakeLists.txt.orig 2025-03-20 22:21:32 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -115,8 +115,10 @@ find_package(BelleSIP 5.3.0 REQUIRED OPTIONAL_COMPONEN
|
|
endif()
|
|
|
|
find_package(BelleSIP 5.3.0 REQUIRED OPTIONAL_COMPONENTS tester)
|
|
+set(CMAKE_PREFIX_PATH "%%LOCALBASE%%/ffmpeg4;%%LOCALBASE%%/ffmpeg4/libexec")
|
|
find_package(Mediastreamer2 5.3.0 REQUIRED)
|
|
find_package(Ortp 5.3.0 REQUIRED)
|
|
+find_package(OpenSSL REQUIRED)
|
|
find_package(BCToolbox 5.3.0 REQUIRED OPTIONAL_COMPONENTS tester)
|
|
#Mandatory to init default compilation flags
|
|
bc_init_compilation_flags(STRICT_OPTIONS_CPP STRICT_OPTIONS_C STRICT_OPTIONS_CXX ENABLE_STRICT)
|
|
@@ -306,7 +308,7 @@ else()
|
|
list(APPEND STRICT_OPTIONS_CPP
|
|
"-Wall"
|
|
"-Wconversion"
|
|
- "-Werror=return-type"
|
|
+ "-Wno-error=return-type"
|
|
"-Winit-self"
|
|
"-Wno-error=deprecated-declarations"
|
|
"-Wpointer-arith"
|