mirror of
https://git.freebsd.org/ports.git
synced 2025-05-13 07:41:50 -04:00
- Add profile support in php-fpm rc script for running multiple php master process Changelog: https://www.php.net/ChangeLog-8.php#8.3.2
54 lines
1.9 KiB
Text
54 lines
1.9 KiB
Text
--- configure.ac.orig 2024-01-16 13:46:41 UTC
|
|
+++ configure.ac
|
|
@@ -55,6 +55,7 @@ AH_BOTTOM([
|
|
|
|
#include <string.h>
|
|
|
|
+#include <ext/php_config.h>
|
|
#endif /* PHP_CONFIG_H */
|
|
])
|
|
|
|
@@ -283,7 +284,6 @@ dnl --------------------------------------------------
|
|
|
|
dnl ----------------------------------------------------------------------------
|
|
|
|
-PTHREADS_CHECK
|
|
PHP_HELP_SEPARATOR([SAPI modules:])
|
|
PHP_SHLIB_SUFFIX_NAMES
|
|
PHP_BUILD_PROGRAM
|
|
@@ -567,7 +567,7 @@ dnl bug #77284. Conservatively don't use ifuncs on Fre
|
|
dnl
|
|
dnl At least some versions of FreeBSD seem to have buggy ifunc support, see
|
|
dnl bug #77284. Conservatively don't use ifuncs on FreeBSD.
|
|
-AS_CASE([$host_alias], [*-*-*android*|*-*-*uclibc*|*-*-*musl*|*freebsd*|*openbsd*], [true], [
|
|
+AS_CASE([$host_alias], [*-*-*android*|*-*-*uclibc*|*-*-*musl*|*openbsd*], [true], [
|
|
AX_GCC_FUNC_ATTRIBUTE([ifunc])
|
|
AX_GCC_FUNC_ATTRIBUTE([target])
|
|
])
|
|
@@ -652,7 +652,7 @@ dnl Some systems (like OpenSolaris) do not have nanosl
|
|
AX_FUNC_WHICH_GETHOSTBYNAME_R
|
|
|
|
dnl Some systems (like OpenSolaris) do not have nanosleep in libc.
|
|
-PHP_CHECK_FUNC_LIB(nanosleep, rt)
|
|
+PHP_CHECK_FUNC(nanosleep, rt)
|
|
|
|
dnl Haiku does not have network api in libc.
|
|
PHP_CHECK_FUNC_LIB(setsockopt, network)
|
|
@@ -1463,7 +1463,7 @@ EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=`eval echo "$PHP_CON
|
|
EXPANDED_DATADIR=$datadir
|
|
EXPANDED_PHP_CONFIG_FILE_PATH=`eval echo "$PHP_CONFIG_FILE_PATH"`
|
|
EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=`eval echo "$PHP_CONFIG_FILE_SCAN_DIR"`
|
|
-INCLUDE_PATH=.:$EXPANDED_PEAR_INSTALLDIR
|
|
+INCLUDE_PATH=.:${prefix}/share/pear
|
|
|
|
exec_prefix=$old_exec_prefix
|
|
libdir=$old_libdir
|
|
@@ -1706,7 +1706,7 @@ PHP_SUBST(install_binary_targets)
|
|
PHP_SUBST(install_targets)
|
|
PHP_SUBST(install_binary_targets)
|
|
|
|
-PHP_INSTALL_HEADERS([Zend/ TSRM/ include/ main/ main/streams/])
|
|
+PHP_INSTALL_HEADERS([Zend/ TSRM/ main/ main/streams/])
|
|
PHP_INSTALL_HEADERS([Zend/Optimizer], [ \
|
|
zend_call_graph.h \
|
|
zend_cfg.h \
|