ports/databases/postgresql-devel/files/patch-contrib::pgcrypto::Makefile
Sean Chittenden 3f2afec718 Repack the -devel port now that version 3.0 of the wire protocol has been
finalized between the client and server.  While here, fix the plist, change
WITH_PGCRYPTO to be WITHOUT_PGCRYPTO that way the port defaults to
installing the crypto libraries.  Now that we have hardware support for
crypto devices, go out of our way to make sure that pgcrypto uses
openssl where applicable and reads from /dev/urandom for entropy.
2003-05-09 01:36:37 +00:00

20 lines
535 B
Text

--- contrib/pgcrypto/Makefile.orig Thu May 8 16:09:28 2003
+++ contrib/pgcrypto/Makefile Thu May 8 16:12:47 2003
@@ -7,7 +7,7 @@
include $(top_builddir)/src/Makefile.global
# either 'builtin', 'mhash', 'openssl'
-cryptolib = builtin
+cryptolib = openssl
# either 'builtin', 'system'
cryptsrc = builtin
@@ -21,7 +21,7 @@
# This works ofcouse only with cryptolib = openssl
#
# 'silly' - use libc random() - very weak
-random = silly
+random = dev
random_dev = \"/dev/urandom\"
##########################