mirror of
https://git.freebsd.org/ports.git
synced 2025-05-13 07:41:50 -04:00
- Builds itself with CMake now and has installation routine - Drop our custom auto-update disabling patches as this is one of the program's standard features now - Explicitly specify desired Qt version so it won't pick up the wrong one accidentally Reported by: portscout
12 lines
410 B
Text
12 lines
410 B
Text
--- CMakeLists.txt.orig 2023-03-08 17:22:01 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -320,7 +320,8 @@ elseif(UNIX)
|
|
string(TOLOWER ${PROJECT_NAME} BINARY_NAME)
|
|
set_target_properties(${PROJECT_NAME} PROPERTIES OUTPUT_NAME ${BINARY_NAME})
|
|
|
|
- target_link_libraries(${PROJECT_NAME} PUBLIC X11)
|
|
+ find_library(X11_LIBRARY X11)
|
|
+ target_link_libraries(${PROJECT_NAME} PUBLIC ${X11_LIBRARY})
|
|
|
|
include(GNUInstallDirs)
|
|
|