mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
December 02, 2024 We (Qt upstream) have released Qt 6.8.1 today. As a patch release, Qt 6.8.1 does not introduce new features but contains more than 550 bug fixes, security updates, and other improvements on top of Qt 6.8.0 release. See more information about the most important changes and bug fixes from the Qt 6.8.1 release note. Announcement: https://www.qt.io/blog/qt-6.8.1-released Release note: https://code.qt.io/cgit/qt/qtreleasenotes.git/about/qt/6.8.1/release-note.md We (kde@) skipped shipping Qt 6.8.0 due to waiting for a compatible version of PyQt to be released, but here are the announcements and release notes from Qt 6.8.0. Announcement: https://www.qt.io/blog/qt-6.8-released Release note: https://code.qt.io/cgit/qt/qtreleasenotes.git/about/qt/6.8.0/release-note.md PySide6: Update to 6.8.0.2 PySide6 and its related components have been updated alongside the Qt release for compatibility. Older versions will not build with Qt 6.8.x. Announcement: https://www.qt.io/blog/qt-for-python-release-6.8 PyQt6: Update to 6.8.0 This release also introduces x11-toolkits/py-qt6-graphs, python bindings for the Qt Graphs module. As with PySide6, older versions of PyQt6 will not build with Qt 6.8.x. Support tools like py-sip and py-qtbuilder have also been updated to their latest versions. Announcement: https://www.riverbankcomputing.com/news/PyQt_v6.8.0_Released Special thanks to Kenneth Raplee for testing and to SponiX for providing access to build hardware! PR: 283290 Exp-run by: antoine (x2)
25 lines
942 B
TOML
25 lines
942 B
TOML
Reduce setuptools requirement until [1] is resolved. Seems to work fine
|
|
with 63.x.
|
|
|
|
[1] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=270358
|
|
|
|
--- pyproject.toml.orig 2024-12-12 09:56:29 UTC
|
|
+++ pyproject.toml
|
|
@@ -1,7 +1,7 @@
|
|
# The project configuration for sip.
|
|
|
|
[build-system]
|
|
-requires = ["setuptools>=64", "setuptools_scm>=8"]
|
|
+requires = ["setuptools>=63", "setuptools_scm>=8"]
|
|
build-backend = "setuptools.build_meta"
|
|
|
|
[tool.setuptools_scm]
|
|
@@ -12,7 +12,7 @@ urls.homepage = "https://github.com/Python-SIP/sip"
|
|
description = "A Python bindings generator for C/C++ libraries"
|
|
readme = "README.md"
|
|
urls.homepage = "https://github.com/Python-SIP/sip"
|
|
-dependencies = ["packaging", "setuptools>=69.5", "tomli; python_version<'3.11'"]
|
|
+dependencies = ["packaging", "setuptools>=63", "tomli; python_version<'3.11'"]
|
|
requires-python = ">=3.9"
|
|
license = {file = "LICENSE"}
|
|
classifiers = ["License :: OSI Approved :: BSD License"]
|