ports/devel/bullet/files/patch-CMakeLists.txt
Dima Panov 0ee4d03db3 devel/bullet: update to 3.21 release
While here, take maintainership

Approved by:	acm (previous maintainer, by mail)
Sponsored by:	Netzkommune GmbH
2021-12-14 21:07:00 +03:00

24 lines
1.1 KiB
Text

--- CMakeLists.txt.orig 2021-05-07 18:04:02 UTC
+++ CMakeLists.txt
@@ -429,9 +429,9 @@ ENDIF(BUILD_OPENGL3_DEMOS)
OPTION(BUILD_BULLET2_DEMOS "Set when you want to build the Bullet 2 demos" ON)
IF(BUILD_BULLET2_DEMOS)
- IF(EXISTS ${BULLET_PHYSICS_SOURCE_DIR}/examples AND IS_DIRECTORY ${BULLET_PHYSICS_SOURCE_DIR}/examples)
- SUBDIRS(examples)
- ENDIF()
+# IF(EXISTS ${BULLET_PHYSICS_SOURCE_DIR}/examples AND IS_DIRECTORY ${BULLET_PHYSICS_SOURCE_DIR}/examples)
+# SUBDIRS(examples)
+# ENDIF()
ENDIF(BUILD_BULLET2_DEMOS)
@@ -470,7 +470,7 @@ IF(INSTALL_LIBS)
SET (LIB_DESTINATION "lib${LIB_SUFFIX}" CACHE STRING "Library directory name")
## the following are directories where stuff will be installed to
SET(INCLUDE_INSTALL_DIR "include/bullet/" CACHE PATH "The subdirectory to the header prefix")
- SET(PKGCONFIG_INSTALL_PREFIX "lib${LIB_SUFFIX}/pkgconfig/" CACHE STRING "Base directory for pkgconfig files")
+ SET(PKGCONFIG_INSTALL_PREFIX "libdata/pkgconfig/" CACHE STRING "Base directory for pkgconfig files")
IF(NOT MSVC)
CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/bullet.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/bullet.pc @ONLY)
INSTALL(