mirror of
https://git.freebsd.org/ports.git
synced 2025-05-03 03:56:39 -04:00
- devel/tex-kpathsea: Update version 6.3.5=>6.4.0 - devel/tex-libtexlua: Update distinfo - devel/tex-synctex: Update distinfo - devel/tex-web2c: Update version 20230313=>20240312 - japanese/tex-ptex: Update distinfo - print/tex-basic-engines: Update version 20230313=>20240312 - print/tex-dvipdfmx: Update version 20230313=>20240312 - print/tex-dvipsk: Update version 20230313=>20240312 - print/tex-jadetex: Update version 20230313=>20240312 - print/tex-luatex: Update version 20230313=>20240312 - print/tex-ptexenc: Update version 1.4.3=>1.4.6 - print/tex-xdvik: Bump REVISION - print/tex-xetex: Update verison 0.99993=>20240312 - print/tex-xmltex: Update verison 1.9=>20240312 - print/texlive-base: Update version 20230313=>20240312 - print/texlive-docs: Update version 20230313=>20240312 - print/texlive-texmf-source: Update version 20230313=>20240312 - print/texlive-texmf: Update version 20230313=>20240312 - print/texlive-tlmgr: Update version 20230313=>20240312 - print/xpdfopen: Update version 0.86=>20240312 Sponsored by: Nepustil
48 lines
1.7 KiB
Text
48 lines
1.7 KiB
Text
--- configure.orig 2024-03-10 21:37:05 UTC
|
|
+++ configure
|
|
@@ -6926,7 +6926,16 @@ fi
|
|
as_fn_error $? "Sorry, \`--with-system-teckit' requires \`--with-system-zlib'" "$LINENO" 5
|
|
fi
|
|
fi
|
|
+# Check whether --with-teckit-includes was given.
|
|
+if test "${with_teckit_includes+set}" = set; then :
|
|
+ withval=$with_teckit_includes;
|
|
+fi
|
|
|
|
+# Check whether --with-teckit-libdir was given.
|
|
+if test "${with_teckit_libdir+set}" = set; then :
|
|
+ withval=$with_teckit_libdir;
|
|
+fi
|
|
+
|
|
test "x$need_teckit" = xyes && {
|
|
need_zlib=yes
|
|
}
|
|
@@ -23616,8 +23625,8 @@ if $FT2_CONFIG --ftversion >/dev/null 2>&1; then
|
|
PKG_CONFIG="$ac_cv_prog_PKG_CONFIG"
|
|
fi
|
|
if $FT2_CONFIG --ftversion >/dev/null 2>&1; then
|
|
- FREETYPE2_INCLUDES=`$FT2_CONFIG --cflags`
|
|
- FREETYPE2_LIBS=`$FT2_CONFIG --libs`
|
|
+ FREETYPE2_INCLUDES=`pkg-config freetype2 --cflags`
|
|
+ FREETYPE2_LIBS=`pkg-config freetype2 --libs`
|
|
elif $PKG_CONFIG --libs freetype2 >/dev/null 2>&1; then
|
|
FREETYPE2_INCLUDES=`$PKG_CONFIG --cflags freetype2`
|
|
FREETYPE2_LIBS=`$PKG_CONFIG --libs freetype2`
|
|
@@ -23691,11 +23700,12 @@ fi
|
|
as_fn_error $? "did not find graphite2" "$LINENO" 5
|
|
fi
|
|
|
|
-if $PKG_CONFIG teckit; then
|
|
- TECKIT_INCLUDES=`$PKG_CONFIG teckit --cflags`
|
|
- TECKIT_LIBS=`$PKG_CONFIG teckit --libs`
|
|
-elif test "x$need_teckit:$with_system_teckit" = xyes:yes; then
|
|
- as_fn_error $? "did not find teckit" "$LINENO" 5
|
|
+if test "x$with_teckit_includes" != x && test "x$with_teckit_includes" != xyes; then
|
|
+ TECKIT_INCLUDES="-I$with_teckit_includes"
|
|
+fi
|
|
+TECKIT_LIBS="-lTECkit"
|
|
+if test "x$with_teckit_libdir" != x && test "x$with_teckit_libdir" != xyes; then
|
|
+ TECKIT_LIBS="-L$with_teckit_libdir $TECKIT_LIBS"
|
|
fi
|
|
|
|
echo 'tldbg:KPSE_ICU_SYSTEM_FLAGS called.' >&5
|