ports/math/faiss/files/patch-perf__tests_CMakeLists.txt
Yuri Victorovich 7a2dc2f8e9 math/{,py-}faiss: update 1.9.0 → 1.11.0
Reported by:	portscout
2025-04-26 20:38:23 -07:00

17 lines
530 B
Text

--- perf_tests/CMakeLists.txt.orig 2025-04-26 22:25:16 UTC
+++ perf_tests/CMakeLists.txt
@@ -7,13 +7,7 @@ set(BENCHMARK_ENABLE_TESTING OFF)
project(faiss_perf_tests)
set(BENCHMARK_ENABLE_TESTING OFF)
-include(FetchContent)
-FetchContent_Declare(googlebenchmark
- GIT_REPOSITORY https://github.com/google/benchmark.git
- GIT_TAG main) # need main for benchmark::benchmark
-FetchContent_MakeAvailable(
- googlebenchmark)
-
+find_package(benchmark)
find_package(Threads REQUIRED)
find_package(OpenMP REQUIRED)