ports/math/sage/files/patch-build_pkgs_python_fbsd-patch-src_Makefile.pre.in
Stephen Montgomery-Smith 7869f4665f - Replace python-2.7.5 with version 2.7.6. Thus the port should now build
on FreeBSD-10 and higher.
- Use the patches from the lang/python27 port.
- Bump portrevision.
2014-05-31 05:05:23 +00:00

54 lines
2 KiB
Text

--- /dev/null 2014-05-31 00:44:00.000000000 +0000
+++ build/pkgs/python/fbsd-patch-src_Makefile.pre.in 2014-05-31 00:35:21.000000000 +0000
@@ -0,0 +1,51 @@
+# Description: Fix out-of-tree build as a result of upstream #15819
+# Submitted by: rm (r318353)
+# Issue ID: http://bugs.python.org/issue15819#msg203348
+
+# Description: Run pycompile only once
+# Submitted by: antoine (r350207)
+# TODO: ?
+
+# Description: Run ranlib before installing the library read-only
+# Submitted by: antoine@ (r350207)
+# TODO: Upstream
+
+--- src/./Makefile.pre.in.orig 2013-11-10 07:36:41.000000000 +0000
++++ src/./Makefile.pre.in 2014-04-04 09:16:00.000000000 +0000
+@@ -285,9 +285,9 @@
+
+ ##########################################################################
+ # AST
+-AST_H_DIR= Include
++AST_H_DIR= $(srcdir)/Include
+ AST_H= $(AST_H_DIR)/Python-ast.h
+-AST_C_DIR= Python
++AST_C_DIR= $(srcdir)/Python
+ AST_C= $(AST_C_DIR)/Python-ast.c
+ AST_ASDL= $(srcdir)/Parser/Python.asdl
+
+@@ -1006,12 +1006,12 @@
+ $(DESTDIR)$(LIBDEST)/distutils/tests ; \
+ fi
+ PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
+- $(PYTHON_FOR_BUILD) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
++ $(PYTHON_FOR_BUILD) -B -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
+ -d $(LIBDEST) -f \
+ -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
+ $(DESTDIR)$(LIBDEST)
+ PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
+- $(PYTHON_FOR_BUILD) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
++ $(PYTHON_FOR_BUILD) -B -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
+ -d $(LIBDEST) -f \
+ -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
+ $(DESTDIR)$(LIBDEST)
+@@ -1089,8 +1089,8 @@
+ if test "$(SO)" = .dll; then \
+ $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
+ else \
++ $(RANLIB) $(LIBRARY) ; \
+ $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
+ fi; \
+ else \
+ echo Skip install of $(LIBRARY) - use make frameworkinstall; \