mirror of
https://git.freebsd.org/ports.git
synced 2025-05-15 16:51:52 -04:00
In preparation for the update of config.guess/config.sub, where amd64-portbld-freebsd14.0 is reported as x86_64-portbld-freebsd14.0, Add a patch to keep the arch specific directory on amd64 being named amd64
36 lines
1.4 KiB
Text
36 lines
1.4 KiB
Text
--- configure.ac.orig 2022-04-12 11:11:15 UTC
|
|
+++ configure.ac
|
|
@@ -1304,7 +1304,7 @@ AC_CHECK_HEADERS(utime.h)
|
|
AC_CHECK_HEADERS(time.h)
|
|
AC_CHECK_HEADERS(ucontext.h)
|
|
AC_CHECK_HEADERS(utime.h)
|
|
-AS_CASE("$target_cpu", [x64|x86_64|i[3-6]86*], [
|
|
+AS_CASE("$target_cpu", [amd64|x64|x86_64|i[3-6]86*], [
|
|
AC_CHECK_HEADERS(x86intrin.h)
|
|
])
|
|
RUBY_UNIVERSAL_CHECK_HEADER([x86_64, i386], x86intrin.h)
|
|
@@ -2982,7 +2982,7 @@ STATIC=
|
|
: ${LDSHARED='$(CC) -shared'}
|
|
AS_IF([test "$rb_cv_binary_elf" = yes], [
|
|
LDFLAGS="$LDFLAGS -rdynamic"
|
|
- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
|
|
+ DLDFLAGS="$DLDFLAGS "'-Wl,-E'
|
|
], [
|
|
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
|
|
])
|
|
@@ -3458,6 +3458,7 @@ AS_CASE("$enable_shared", [yes], [
|
|
[freebsd*|dragonfly*], [
|
|
LIBRUBY_SO='lib$(RUBY_SO_NAME).$(SOEXT).$(MAJOR)$(MINOR)'
|
|
LIBRUBY_SONAME='$(LIBRUBY_SO)'
|
|
+ RUBY_APPEND_OPTIONS(LIBRUBY_DLDFLAGS, ['-Wl,-soname,${LIBRUBY_SO}'])
|
|
AS_IF([test "$rb_cv_binary_elf" != "yes" ], [
|
|
LIBRUBY_SO="$LIBRUBY_SO.\$(TEENY)"
|
|
LIBRUBY_ALIASES=''
|
|
@@ -4103,6 +4104,7 @@ AS_IF([test "${universal_binary-no}" = yes ], [
|
|
arch="${target_cpu}-mingw-ucrt"
|
|
], [
|
|
arch="${target_cpu}-${target_os}"
|
|
+ AS_CASE(["$target_cpu-$target_os"], [x86_64-freebsd*],[arch=amd64-${target_os}])
|
|
])
|
|
AC_DEFINE_UNQUOTED(RUBY_PLATFORM, "$arch")
|
|
])
|