mirror of
https://git.freebsd.org/ports.git
synced 2025-05-29 01:16:28 -04:00
GCC 11, GCC 12 and GCC 13 install libgccjit.h and libgccjit++.h in the
same directory.
Fix conflict for lang/gcc12, which is soon to become GCC_DEFAULT, by
installing those files in a directory specific to GCC 12.
See also commit 0338e04504
that fixed the
conflict in the same way for lang/gcc11.
PR: 257060
19 lines
935 B
Text
19 lines
935 B
Text
--- gcc/Makefile.in.orig 2022-11-02 20:13:34 UTC
|
|
+++ gcc/Makefile.in
|
|
@@ -630,6 +630,8 @@ libsubdir = $(libdir)/gcc/$(real_target_noncanonical)/
|
|
|
|
# Directory in which the compiler finds libraries etc.
|
|
libsubdir = $(libdir)/gcc/$(real_target_noncanonical)/$(version)$(accel_dir_suffix)
|
|
+# Directory in which the compiler finds headers.
|
|
+libsubincludedir = $(libdir)/gcc/$(target_alias)/$(version)/include
|
|
# Directory in which the compiler finds executables
|
|
libexecsubdir = $(libexecdir)/gcc/$(real_target_noncanonical)/$(version)$(accel_dir_suffix)
|
|
# Directory in which all plugin resources are installed
|
|
@@ -3609,6 +3611,7 @@ installdirs:
|
|
# $(libdir)/gcc/include isn't currently searched by cpp.
|
|
installdirs:
|
|
$(mkinstalldirs) $(DESTDIR)$(libsubdir)
|
|
+ $(mkinstalldirs) $(DESTDIR)$(libsubincludedir)
|
|
$(mkinstalldirs) $(DESTDIR)$(libexecsubdir)
|
|
$(mkinstalldirs) $(DESTDIR)$(bindir)
|
|
$(mkinstalldirs) $(DESTDIR)$(includedir)
|