mirror of
https://git.freebsd.org/ports.git
synced 2025-05-13 15:51:51 -04:00
This is the second attempt to solve the conflict, see commits -dc67e7d300
(first attempt); -9f0cd13014
(revert of the first attempt). GCC 11, GCC 12 and GCC 13 install libgccjit.h and libgccjit++.h in the same directory. Fix conflict for GCC 11, which is GCC_DEFAULT, by installing those files in a directory specific to GCC 11. PR: 257060 Reviewed by: yasu, jrm Differential Revision: https://reviews.freebsd.org/D37266
19 lines
935 B
Text
19 lines
935 B
Text
--- gcc/Makefile.in.orig 2022-11-02 20:13:34 UTC
|
|
+++ gcc/Makefile.in
|
|
@@ -630,6 +630,8 @@ libsubdir = $(libdir)/gcc/$(real_target_noncanonical)/
|
|
|
|
# Directory in which the compiler finds libraries etc.
|
|
libsubdir = $(libdir)/gcc/$(real_target_noncanonical)/$(version)$(accel_dir_suffix)
|
|
+# Directory in which the compiler finds headers.
|
|
+libsubincludedir = $(libdir)/gcc/$(target_alias)/$(version)/include
|
|
# Directory in which the compiler finds executables
|
|
libexecsubdir = $(libexecdir)/gcc/$(real_target_noncanonical)/$(version)$(accel_dir_suffix)
|
|
# Directory in which all plugin resources are installed
|
|
@@ -3609,6 +3611,7 @@ installdirs:
|
|
# $(libdir)/gcc/include isn't currently searched by cpp.
|
|
installdirs:
|
|
$(mkinstalldirs) $(DESTDIR)$(libsubdir)
|
|
+ $(mkinstalldirs) $(DESTDIR)$(libsubincludedir)
|
|
$(mkinstalldirs) $(DESTDIR)$(libexecsubdir)
|
|
$(mkinstalldirs) $(DESTDIR)$(bindir)
|
|
$(mkinstalldirs) $(DESTDIR)$(includedir)
|