mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 17:46:38 -04:00
* Upstream switched to Meson Changelog: https://gitlab.gnome.org/GNOME/librsvg/-/releases/2.60.0 Thanks to mikael@ and fluffy@ for testing and suggesting fixes including for consumers PR: 284977 Tested by: fluffy Approved by: desktop (vishwin (previous version), fluffy)
11 lines
453 B
Text
11 lines
453 B
Text
--- rsvg/meson.build.orig 2025-03-29 19:19:55 UTC
|
|
+++ rsvg/meson.build
|
|
@@ -171,7 +171,7 @@ else
|
|
if host_system in ['darwin', 'ios']
|
|
vflag = '-Wl,-exported_symbols_list,@0@'.format(version_script)
|
|
else
|
|
- vflag = '-Wl,--version-script,@0@'.format(version_script)
|
|
+ vflag = '-Wl,--undefined-version,--version-script,@0@'.format(version_script)
|
|
endif
|
|
|
|
# This is not strictly needed, but since we are telling Cargo to build a staticlib, it puts in
|