mirror of
https://git.freebsd.org/ports.git
synced 2025-05-20 11:03:09 -04:00
Merge all changes from databases/redis-devel to databases/redis. <ChangeLog> Redis 3.0 release notes ======================= --[ Redis 3.0.0 ] Release date: 1 Apr 2015 >> What's new in Redis 3.0 compared to Redis 2.8? * Redis Cluster: a distributed implementation of a subset of Redis. * New "embedded string" object encoding resulting in less cache misses. Big speed gain under certain work loads. * AOF child -> parent final data transmission to minimize latency due to "last write" during AOF rewrites. * Much improved LRU approximation algorithm for keys eviction. * WAIT command to block waiting for a write to be transmitted to the specified number of slaves. * MIGRATE connection caching. Much faster keys migraitons. * MIGARTE new options COPY and REPLACE. * CLIENT PAUSE command: stop processing client requests for a specified amount of time. * BITCOUNT performance improvements. * CONFIG SET accepts memory values in different units (for example you can use "CONFIG SET maxmemory 1gb"). * Redis log format slightly changed reporting in each line the role of the instance (master/slave) or if it's a saving child log. * INCR performance improvements. >> Refactoring changes (no new features nor bug fixes) * Blocking operations full refactoring (blocked.c) * Client output buffer memory tracking refactored. </ChangeLog>
15 lines
342 B
Text
15 lines
342 B
Text
--- deps/linenoise/Makefile.orig 2015-01-17 22:13:25.000000000 +0300
|
|
+++ deps/linenoise/Makefile 2015-01-17 22:13:45.000000000 +0300
|
|
@@ -1,10 +1,10 @@
|
|
STD=
|
|
WARN= -Wall
|
|
-OPT= -Os
|
|
+#OPT= -Os
|
|
|
|
R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
|
|
R_LDFLAGS= $(LDFLAGS)
|
|
-DEBUG= -g
|
|
+#DEBUG= -g
|
|
|
|
R_CC=$(CC) $(R_CFLAGS)
|
|
R_LD=$(CC) $(R_LDFLAGS)
|