ports/lang/tcbasic/files/patch-CMakeLists.txt
mew14930xvi 5717daedf4 lang/tcbasic: Update to 2.3.0
ChangeLog: https://github.com/tcort/tcbasic/releases/tag/v2.3.0

 * Add FOR/NEXT loops
 * Add integer division operator (\) and exponentiation operator (^)
 * Add built-in functions: CLS, INT, SHELL, BEEP
 * Allow spaces between GO and TO as well as GO and SUB.
 * Allow mixed case keywords
 * Improved error checking and reporting
 * Switch from autotools build system to cmake build system
 * Increase randomness of RANDOMIZE
 * Documentation updates

PR:		278067
Reported by:	mew14930xvi@inbox.lv
Approved by:	linuxgeek@gmail.com (maintainer, timeout > 2 weeks)
2024-04-21 14:06:05 +02:00

12 lines
510 B
Text

--- CMakeLists.txt.orig 2020-11-17 19:28:20 UTC
+++ CMakeLists.txt
@@ -38,8 +38,7 @@ install(TARGETS tcbasic DESTINATION bin)
add_executable(tcbasic ${SOURCES})
target_link_libraries(tcbasic m)
install(TARGETS tcbasic DESTINATION bin)
-install(FILES ${PROJECT_BINARY_DIR}/man/tcbasic.1 DESTINATION man/man1)
-install(DIRECTORY ${PROJECT_SOURCE_DIR}/examples DESTINATION share/${PROJECT_NAME})
+install(FILES ${PROJECT_BINARY_DIR}/man/tcbasic.1 DESTINATION share/man/man1)
include(CTest)
enable_testing()