mirror of
https://git.freebsd.org/ports.git
synced 2025-05-28 00:46:27 -04:00
- VCMI mod now uses same filesystem as all mods, with all files located under `Content' directory - Moved all PNG images from `Data' directory to `Sprites' - Use `TTF_Font' type provided by <SDL_ttf.h> to unbreak the build against `graphics/sdl2_ttf' version 2.24.0 - Add `post-patch' target to prevent accidentally picking up Qt 6 bits if they're installed (always prefer Qt 5) PR: 283866
14 lines
465 B
Text
14 lines
465 B
Text
--- lib/CMakeLists.txt.orig 2025-01-09 19:59:03 UTC
|
|
+++ lib/CMakeLists.txt
|
|
@@ -793,6 +793,11 @@ if(WIN32)
|
|
)
|
|
endif()
|
|
|
|
+if(BSD)
|
|
+ set_source_files_properties(CConsoleHandler.cpp PROPERTIES
|
|
+ COMPILE_FLAGS -DBOOST_STACKTRACE_GNU_SOURCE_NOT_REQUIRED)
|
|
+endif(BSD)
|
|
+
|
|
# Use '-Wa,-mbig-obj' for files that generate very large object files
|
|
# when compiling with MinGW lest you get "too many sections" assembler errors
|
|
if(MINGW AND CMAKE_BUILD_TYPE STREQUAL "Debug")
|