ports/databases/redis/files/patch-src::Makefile
Sergey A. Osokin 0b43809cb1 Update from 2.2.12 to latest bugfix release 2.2.13.
<ChangeLog>

* [BUGFIX] Fixed issue 593 (BRPOPLPUSH related crash).
* [BUGFIX] Fixed an issue with the networking layer that may
  prevent Redis from sending the whole reply back to client
  under extreme conditions.

</ChangeLog>
2011-09-14 06:39:19 +00:00

24 lines
682 B
Text

--- src/Makefile.orig 2011-09-14 10:32:32.000000000 +0400
+++ src/Makefile 2011-09-14 10:34:08.000000000 +0400
@@ -22,6 +22,9 @@
CFLAGS?= -std=c99 -pedantic $(OPTIMIZATION) -Wall -W -D__EXTENSIONS__ -D_XPG6
CCLINK?= -ldl -lnsl -lsocket -lm -lpthread
DEBUG?= -g -ggdb
+else ifeq ($(uname_S),FreeBSD)
+ CFLAGS?= $(CFLAGS)
+ CCLINK?= -pthread -lm
else
CFLAGS?= -std=c99 -pedantic $(OPTIMIZATION) -Wall -W $(ARCH) $(PROF)
CCLINK?= -lm -pthread
@@ -32,9 +35,9 @@
CCLINK+= -ltcmalloc
CFLAGS+= -DUSE_TCMALLOC
endif
-CCOPT= $(CFLAGS) $(ARCH) $(PROF)
+CCOPT= $(CFLAGS) $(PROF)
-PREFIX= /usr/local
+PREFIX?= $(PREFIX)
INSTALL_BIN= $(PREFIX)/bin
INSTALL= cp -p