mirror of
https://git.freebsd.org/ports.git
synced 2025-05-29 01:16:28 -04:00
Firebird is a relational database offering many ANSI SQL-99 features that runs on Linux, Windows, and a variety of Unix platforms. Firebird offers excellent concurrency, high performance, and powerful language support for stored procedures and triggers. It has been used in production systems, under a variety of names since 1981. Firebird is completely free of any registration, licensing or deployment fees. It may be deployed freely for use with any third-party software, whether commercial or not. WWW: http://sourceforge.net/projects/firebird/ WWW: http://www.firebirdsql.org/ PR: 152402 Submitted by: Max Kochubey <root at hangover.org.ru>
45 lines
1.4 KiB
Text
45 lines
1.4 KiB
Text
--- builds/posix/Makefile.in.firebird.orig 2008-12-10 21:22:15.000000000 +0600
|
|
+++ builds/posix/Makefile.in.firebird 2010-10-19 12:36:20.000000000 +0700
|
|
@@ -185,9 +185,6 @@
|
|
#
|
|
|
|
external_libraries:
|
|
-ifeq ($(STD_ICU),false)
|
|
- $(MAKE) -f $(GEN_ROOT)/Makefile.extern.icu
|
|
-endif
|
|
ifeq ($(STD_EDITLINE),false)
|
|
ifeq ($(EDITLINE_FLG),Y)
|
|
$(MAKE) -f $(GEN_ROOT)/Makefile.extern.editline
|
|
@@ -519,12 +516,12 @@
|
|
#___________________________________________________________________________
|
|
#
|
|
.PHONY: clean clean_objects clean_dependancies clean_extern_objects clean_build \
|
|
- clean_gpre_gen clean_icu clean_dbs clean_examples clean_makefiles \
|
|
+ clean_gpre_gen clean_dbs clean_examples clean_makefiles \
|
|
clean_editline clean_all
|
|
|
|
|
|
clean: clean_objects clean_dependancies clean_extern_objects clean_build \
|
|
- clean_yacc_gen clean_gpre_gen clean_icu clean_dbs clean_examples
|
|
+ clean_yacc_gen clean_gpre_gen clean_dbs clean_examples
|
|
|
|
ifeq ($(EDITLINE_FLG),Y)
|
|
clean: clean_editline
|
|
@@ -538,7 +535,6 @@
|
|
$(RM) $(ROOT)/libtool
|
|
$(RM_R) $(ROOT)/autom4te.cache
|
|
-make -C $(ROOT)/extern/editline distclean
|
|
- -make -C $(ROOT)/extern/icu/source distclean
|
|
-make -C $(ROOT)/extern/btyacc distclean
|
|
|
|
clean_dbs:
|
|
@@ -551,9 +547,6 @@
|
|
clean_editline:
|
|
-make -C $(ROOT)/extern/editline clean
|
|
|
|
-clean_icu:
|
|
- -make -C $(ROOT)/extern/icu/source clean
|
|
-
|
|
clean_objects:
|
|
$(RM) `find $(TMP_ROOT)/ -type f -name '*.o' -print`
|
|
|