mirror of
https://git.freebsd.org/ports.git
synced 2025-05-03 12:06:39 -04:00
The filesystems category houses file systems and file system utilities. It is added mainly to turn the sysutils/fusefs-* pseudo-category into a proper one, but is also useful for the sundry of other file systems related ports found in the tree. Ports that seem like they belong there are moved to the new category. Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are not moved as they currently don't fetch and don't have TIMESTAMP set in their distinfo, but that is required to be able to push a rename of the port by the pre-receive hook. Approved by: portmgr (rene) Reviewed by: mat Pull Request: https://github.com/freebsd/freebsd-ports/pull/302 PR: 281988
29 lines
896 B
C
29 lines
896 B
C
--- scsi.c.orig 2018-12-02 16:23:26 UTC
|
|
+++ scsi.c
|
|
@@ -62,7 +62,7 @@
|
|
#include <sys/scsicmd.h>
|
|
#endif
|
|
|
|
-#if (defined(OS_freebsd)) && (__FreeBSD__ >= 2)
|
|
+#if (defined(OS_freebsd)) && (__FreeBSD__ >= 3)
|
|
#include <camlib.h>
|
|
#endif
|
|
|
|
@@ -82,7 +82,7 @@ int scsi_max_length(void)
|
|
int scsi_open(const char *name, int flag UNUSEDP, int mode UNUSEDP,
|
|
void **extra_data UNUSEDP)
|
|
{
|
|
-#if (defined(OS_freebsd)) && (__FreeBSD__ >= 2)
|
|
+#if (defined(OS_freebsd)) && (__FreeBSD__ >= 3)
|
|
struct cam_device *cam_dev;
|
|
cam_dev = cam_open_device(name, O_RDWR);
|
|
*extra_data = (void *) cam_dev;
|
|
@@ -245,7 +245,7 @@ int scsi_cmd(int fd, unsigned char *cdb, int cmdlen, s
|
|
}
|
|
|
|
return 0;
|
|
-#elif (defined OS_freebsd) && (__FreeBSD__ >= 2)
|
|
+#elif (defined OS_freebsd) && (__FreeBSD__ >= 3)
|
|
#define MSG_SIMPLE_Q_TAG 0x20 /* O/O */
|
|
union ccb *ccb;
|
|
int flags;
|