mirror of
https://git.freebsd.org/ports.git
synced 2025-04-30 02:26:38 -04:00
13 lines
414 B
Text
13 lines
414 B
Text
--- CMakeLists.txt.orig 2023-01-17 00:20:58 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -1,3 +1,10 @@
|
|
+
|
|
+cmake_minimum_required(VERSION 3.8)
|
|
+
|
|
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/../cmake_modules" "${CMAKE_SOURCE_DIR}/../cmake_modules/yacma")
|
|
+
|
|
+include(YACMAPythonSetup)
|
|
+
|
|
# Python version check.
|
|
if(${PYTHON_VERSION_MAJOR} LESS 3)
|
|
message(FATAL_ERROR "Minimum supported Python version is 3.0")
|