ports/ftp/wzdftpd/files/patch-Makefile.am
Robert Clausecker 2f04ed793d ftp/wzdftpd: fix build with LLVM 15
Seems like the compiler got a whole lot stricter with this release.
The biggest fix was changing the thread ID from unsigned long to
pthread_t, which will probably break compilation on Win32.

While we are at it, replace static uses of REINPLACE_CMD with patch
files as per policy.  This change is responsible for most of the
newly added patches.

The wzdftpd build scripts want to install plugins into ${PREFIX}/share
when they belong into ${PREFIX}/lib.  Instead of patching this in each
Makefile.am, set --datadir=${PREFIX}/lib and work around the one file
for which this is wrong.

Approved by:	eduardo (mentor)
Differential Revision: https://reviews.freebsd.org/D38523
2023-02-14 21:23:41 +01:00

7 lines
143 B
Text

--- Makefile.am.orig 2023-02-11 10:33:06 UTC
+++ Makefile.am
@@ -20,3 +20,4 @@ doxy:
doxygen doxygen.cfg
+ACLOCAL_AMFLAGS= -I ac-helpers