ports/filesystems/cramfs/files/patch-mkcramfs.c
Robert Clausecker 6e2da9672f filesystems: add new category for file systems and related utilities
The filesystems category houses file systems and file system utilities.
It is added mainly to turn the sysutils/fusefs-* pseudo-category into
a proper one, but is also useful for the sundry of other file systems
related ports found in the tree.

Ports that seem like they belong there are moved to the new category.
Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are
not moved as they currently don't fetch and don't have TIMESTAMP set
in their distinfo, but that is required to be able to push a rename
of the port by the pre-receive hook.

Approved by:	portmgr (rene)
Reviewed by:	mat
Pull Request:	https://github.com/freebsd/freebsd-ports/pull/302
PR:		281988
2024-11-06 16:17:35 +01:00

12 lines
356 B
C

--- mkcramfs.c.orig Wed Nov 29 12:47:30 2006
+++ mkcramfs.c Wed Nov 29 12:49:25 2006
@@ -36,6 +36,9 @@
#include <linux/cramfs_fs.h>
#include <zlib.h>
+#define MAP_ANONYMOUS MAP_ANON
+typedef long long loff_t;
+
/* Exit codes used by mkfs-type programs */
#define MKFS_OK 0 /* No errors */
#define MKFS_ERROR 8 /* Operational error */