mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 23:31:50 -04:00
urllib3.future is a powerful, user-friendly HTTP client for Python. urllib3.future goes beyond supported features while remaining compatible. urllib3.future brings many critical features that are missing from both the Python standard libraries and urllib3: - Async. - Task safety. - Thread safety. - Happy Eyeballs. - Connection pooling. - Unopinionated about OpenSSL. - Client-side SSL/TLS verification. - Highly customizable DNS resolution. - File uploads with multipart encoding. - DNS over UDP, TLS, QUIC, or HTTPS. DNSSEC protected. - Helpers for retrying requests and dealing with HTTP redirects. - Automatic Keep-Alive for HTTP/1.1, HTTP/2, and HTTP/3. - Support for gzip, deflate, brotli, and zstd encoding. - Support for Python/PyPy 3.7+, no compromise. - Automatic Connection Upgrade / Downgrade. - Early (Informational) Responses / Hints. - HTTP/1.1, HTTP/2 and HTTP/3 support. - WebSocket over HTTP/2+ (RFC8441). - Proxy support for HTTP and SOCKS. - Post-Quantum Security with QUIC. - Detailed connection inspection. - HTTP/2 with prior knowledge. - Server Side Event (SSE). - Multiplexed connection. - Mirrored Sync & Async. - Trailer Headers. - Amazingly Fast. - WebSocket. urllib3.future is powerful and easy to use.
11 lines
1.4 KiB
TOML
11 lines
1.4 KiB
TOML
--- pyproject.toml.orig 2024-12-22 10:26:46 UTC
|
|
+++ pyproject.toml
|
|
@@ -40,7 +40,7 @@ dependencies = [
|
|
requires-python = ">=3.7"
|
|
dynamic = ["version"]
|
|
dependencies = [
|
|
- "qh3>=1.2.0,<2.0.0; (platform_python_implementation != 'CPython' or python_full_version > '3.7.10') and (platform_system == 'Darwin' or platform_system == 'Windows' or platform_system == 'Linux') and (platform_machine == 'x86_64' or platform_machine == 's390x' or platform_machine == 'aarch64' or platform_machine == 'armv7l' or platform_machine == 'ppc64le' or platform_machine == 'ppc64' or platform_machine == 'AMD64' or platform_machine == 'arm64' or platform_machine == 'ARM64') and (platform_python_implementation == 'CPython' or (platform_python_implementation == 'PyPy' and python_version < '3.11'))",
|
|
+ "qh3>=1.0.0,<2.0.0; (platform_python_implementation != 'CPython' or python_full_version > '3.7.10') and (platform_system == 'Darwin' or platform_system == 'Windows' or platform_system == 'Linux') and (platform_machine == 'x86_64' or platform_machine == 's390x' or platform_machine == 'aarch64' or platform_machine == 'armv7l' or platform_machine == 'ppc64le' or platform_machine == 'ppc64' or platform_machine == 'AMD64' or platform_machine == 'arm64' or platform_machine == 'ARM64') and (platform_python_implementation == 'CPython' or (platform_python_implementation == 'PyPy' and python_version < '3.11'))",
|
|
"h11>=0.11.0,<1.0.0",
|
|
"jh2>=5.0.3,<6.0.0",
|
|
]
|