ports/www/py-django-smart-selects/files/patch-setup.py
Kai Knoblich 2328d0f164 www/py-django-smart-selects: Update to 1.6.0
* Remove LICENSE from ${FILESDIR} as the license file is already
  supplied with the sdist.

* devel/py-setuptools-scm is only required for build as it's also
  defined in setup.py.

* Prevent the installation of the test suite to avoid installation
  conflicts. [1]

Changelog:

https://github.com/jazzband/django-smart-selects/releases/tag/1.6.0

PR:		277000, 262759 [1]
Approved by:	maintainer timeout (3+ weeks)
2024-03-09 15:29:09 +01:00

14 lines
486 B
Python

Avoid the installation of the test suite in the top-level directory
of ${PYTHON_SITELIBDIR}.
--- setup.py.orig 2024-02-12 05:03:25 UTC
+++ setup.py
@@ -14,7 +14,7 @@ setup(
author="Patrick Lauber",
author_email="digi@treepy.com",
url="https://github.com/jazzband/django-smart-selects",
- packages=find_packages(),
+ packages=find_packages(exclude=['test_app*']),
include_package_data=True,
python_requires=">=3.6",
install_requires=["django>=2.2"],