mirror of
https://git.freebsd.org/ports.git
synced 2025-05-01 02:56:39 -04:00
15 lines
568 B
TOML
15 lines
568 B
TOML
--- pyproject.toml.orig 2024-08-20 08:36:08 UTC
|
|
+++ pyproject.toml
|
|
@@ -1,10 +1,10 @@ requires = [
|
|
[build-system]
|
|
requires = [
|
|
'setuptools',
|
|
- 'Cython == 3.0.10',
|
|
+ 'Cython >= 3.0.10',
|
|
# https://numpy.org/devdocs/user/depending_on_numpy.html#build-time-dependency
|
|
# from https://github.com/scipy/oldest-supported-numpy/pull/78#issuecomment-1747936818:
|
|
- "oldest-supported-numpy; platform_python_implementation != 'PyPy'",
|
|
+ "numpy; platform_python_implementation != 'PyPy'",
|
|
"numpy < 2.0.0; platform_python_implementation=='PyPy'",
|
|
'hypothesis'
|
|
]
|