ports/dns/https_dns_proxy/files/patch-CMakeLists.txt
Alexey Dokuchaev 6b11474239 net/https_dns_proxy: new port had been added (+)
Light-weight (written in plain C) DNS-HTTPS, non-caching translation
proxy when DNSCrypt-Proxy does not quite fit (or even does not work).

WWW: https://github.com/aarond10/https_dns_proxy
2024-02-08 03:05:54 +00:00

20 lines
751 B
Text

--- CMakeLists.txt.orig 2023-12-26 21:36:07 UTC
+++ CMakeLists.txt
@@ -67,6 +67,7 @@ endif()
find_path(LIBCARES_INCLUDE_DIR ares.h)
find_path(LIBEV_INCLUDE_DIR ev.h)
+cmake_path(GET LIBEV_INCLUDE_DIR PARENT_PATH LOCALBASE)
if(CUSTOM_LIBCURL_INSTALL_PATH)
message(STATUS "Using custom libcurl from: ${CUSTOM_LIBCURL_INSTALL_PATH}")
@@ -108,7 +109,8 @@ set(TARGET_NAME "https_dns_proxy")
aux_source_directory(src SRC_LIST)
set(SRC_LIST ${SRC_LIST})
add_executable(${TARGET_NAME} ${SRC_LIST})
-set(LIBS ${LIBS} cares curl ev resolv)
+set(LIBS ${LIBS} cares curl ev)
+target_link_directories(${TARGET_NAME} PRIVATE ${LOCALBASE}/lib)
target_link_libraries(${TARGET_NAME} ${LIBS})
set_property(TARGET ${TARGET_NAME} PROPERTY C_STANDARD 11)