mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
N.B. the wrinkle in cmake build here. find_package(Pythoninterp 3.4 REQUIRED) can find your install Python 3.9 instead of the DEFAULT Python. Force the correct one with a few patches. PR: ports/251236 Submitted by: sko@rostwald.de Reported by: trombik1973@gmail.com
30 lines
1.1 KiB
Text
30 lines
1.1 KiB
Text
--- CMakeLists.txt.orig 2020-04-16 10:34:42 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -15,13 +15,27 @@ else()
|
|
find_package(Python3 3.4 REQUIRED COMPONENTS Interpreter)
|
|
endif()
|
|
|
|
+if (NOT PYTHON_EXECUTABLE STREQUAL "" )
|
|
+ set(Python3_EXECUTABLE ${PYTHON_EXECUTABLE})
|
|
+ message("Using given PYTHON_EXECUTABLE")
|
|
+endif()
|
|
+if (NOT PYTHONPREFIX_SITELIBDIR STREQUAL "")
|
|
+ set(PYTHONPREFIX_SITELIBDIR ${PYTHONPREFIX_SITELIBDIR})
|
|
+ message("Using given PYTHONPREFIX_SITELIBDIR")
|
|
+endif()
|
|
+
|
|
option(INSTALL_SERVICE "Install the Charon DBus-service" ON)
|
|
option(INSTALL_CLIENT "Install the Charon Client library" ON)
|
|
|
|
+if ( NOT PYTHONPREFIX_SITELIBDIR STREQUAL "")
|
|
+ message("Using given PYTHONPREFIX_SITELIBDIR for CHARON_INSTALL_PATH")
|
|
+ set(CHARON_INSTALL_PATH ${PYTHONPREFIX_SITELIBDIR})
|
|
+else()
|
|
if(EXISTS /etc/debian_version)
|
|
set(CHARON_INSTALL_PATH lib${LIB_SUFFIX}/python${Python3_VERSION_MAJOR}/dist-packages)
|
|
else()
|
|
set(CHARON_INSTALL_PATH lib${LIB_SUFFIX}/python${Python3_VERSION_MAJOR}.${Python3_VERSION_MINOR}/site-packages)
|
|
+endif()
|
|
endif()
|
|
|
|
set(_excludes PATTERN __pycache__ EXCLUDE)
|