mirror of
https://git.freebsd.org/ports.git
synced 2025-04-30 18:46:38 -04:00
The filesystems category houses file systems and file system utilities. It is added mainly to turn the sysutils/fusefs-* pseudo-category into a proper one, but is also useful for the sundry of other file systems related ports found in the tree. Ports that seem like they belong there are moved to the new category. Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are not moved as they currently don't fetch and don't have TIMESTAMP set in their distinfo, but that is required to be able to push a rename of the port by the pre-receive hook. Approved by: portmgr (rene) Reviewed by: mat Pull Request: https://github.com/freebsd/freebsd-ports/pull/302 PR: 281988
14 lines
414 B
C
14 lines
414 B
C
--- path_utils.h.orig 2007-11-20 19:27:58 UTC
|
|
+++ path_utils.h
|
|
@@ -6,4 +6,11 @@ char* get_full_path(const char* path);
|
|
char* get_fulldir_path(const char* path);
|
|
char* get_dir_path(const char* path);
|
|
|
|
+/*
|
|
+ * Transforms UNIX path to RFC3986 encoded path
|
|
+ * (CURLOPT_URL accepts only such paths)
|
|
+ */
|
|
+char* path_to_uri(const char* path);
|
|
+void free_uri(char* path);
|
|
+
|
|
#endif /* __CURLFTPFS_PATH_UTILS_H__ */
|