mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
- update firefox-esr, thunderbird, linux-firefox, linux-thunderbird to 17.0.3 - update linux-seamonkey to 2.16 - update nspr to 4.9.5 - update nss to 3.14.3 - add DuckDuckGo search plugin to firefox [1] - mark kompozer deprecated - clang fixes for www/libxul19 [2] Security: http://www.vuxml.org/freebsd/e3f0374a-7ad6-11e2-84cd-d43d7e0c7c02.html Submitted by: DuckDuckGo [1], dim [2] In collaboration with: Jan Beich <jbeich@tormail.org>
12 lines
488 B
Makefile
12 lines
488 B
Makefile
--- ../coreconf/rules.mk.orig Sat Jan 6 00:48:54 2007
|
|
+++ ../coreconf/rules.mk Fri Mar 23 10:15:46 2007
|
|
@@ -114,6 +114,9 @@
|
|
endif
|
|
ifdef SHARED_LIBRARY
|
|
$(INSTALL) -m 775 $(SHARED_LIBRARY) $(SOURCE_LIB_DIR)
|
|
+ifndef MOZILLA_CLIENT
|
|
+ ln -sf $(notdir $(SHARED_LIBRARY)) $(SOURCE_LIB_DIR)/$(notdir $(SHARED_LIBRARY:.so.1=.so))
|
|
+endif
|
|
ifdef MOZ_DEBUG_SYMBOLS
|
|
ifeq (,$(filter-out _WIN%,$(NS_USE_GCC)_$(OS_TARGET)))
|
|
$(INSTALL) -m 644 $(SHARED_LIBRARY:$(DLL_SUFFIX)=pdb) $(SOURCE_LIB_DIR)
|