ports/java/jdk16/files/patch-j2se-splashscreen-Makefile
Greg Lewis a7d5955455 . When building libsplashscreen, put the internal JDK header paths before
the external system header paths.  This prevents us from picking up the
  jpeg headers from the system headers when building splashscreen_jpeg.c
  which caused an undefined reference to be present in libsplashscreen
  since the internal JDK jpeg headers remap the function names.

PR:		119654
2008-10-15 03:34:38 +00:00

32 lines
1.2 KiB
Text

$FreeBSD$
--- ../../j2se/make/sun/splashscreen/Makefile.orig 2008-10-13 20:02:03.000000000 -0700
+++ ../../j2se/make/sun/splashscreen/Makefile 2008-10-14 18:53:48.000000000 -0700
@@ -45,9 +45,16 @@
ifneq ($(PLATFORM), windows)
CFLAGS += -DWITH_X11
+endif
+
+# Internal JDK include paths should come before system include paths
+CPPFLAGS += -I$(PLATFORM_SRC)/native/$(PKGDIR)/splashscreen -I$(SHARE_SRC)/native/$(PKGDIR)/splashscreen
+CPPFLAGS += -I$(SHARE_SRC)/native/$(PKGDIR)/image/jpeg -I$(SHARE_SRC)/native/java/util/zip/zlib-1.1.3
+
+ifneq ($(PLATFORM), windows)
ifeq ($(PLATFORM), bsd)
ifneq ($(OS_VENDOR), NetBSD)
- ICONV_DIR = /usr/local
+ ICONV_DIR = ${LOCALBASE}
ICONV_LIB = -L$(ICONV_DIR)/lib -liconv
endif
CPPFLAGS += -I$(OPENWIN_HOME)/include \
@@ -75,9 +82,6 @@
vpath %.c $(SHARE_SRC)/native/$(PKGDIR)/image/jpeg
vpath %.c $(PLATFORM_SRC)/native/$(PKGDIR)/splashscreen
-CPPFLAGS += -I$(PLATFORM_SRC)/native/$(PKGDIR)/splashscreen -I$(SHARE_SRC)/native/$(PKGDIR)/splashscreen
-CPPFLAGS += -I$(SHARE_SRC)/native/$(PKGDIR)/image/jpeg -I$(SHARE_SRC)/native/java/util/zip/zlib-1.1.3
-
#
# Has been converted to the JNI: generate JNI-style header files
#