mirror of
https://git.freebsd.org/ports.git
synced 2025-04-29 18:16:48 -04:00
The filesystems category houses file systems and file system utilities. It is added mainly to turn the sysutils/fusefs-* pseudo-category into a proper one, but is also useful for the sundry of other file systems related ports found in the tree. Ports that seem like they belong there are moved to the new category. Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are not moved as they currently don't fetch and don't have TIMESTAMP set in their distinfo, but that is required to be able to push a rename of the port by the pre-receive hook. Approved by: portmgr (rene) Reviewed by: mat Pull Request: https://github.com/freebsd/freebsd-ports/pull/302 PR: 281988
19 lines
621 B
C
19 lines
621 B
C
--- libxfs/rdwr.c.orig 2015-07-24 04:28:04 UTC
|
|
+++ libxfs/rdwr.c
|
|
@@ -16,6 +16,7 @@
|
|
* Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
|
|
*/
|
|
|
|
+#include <inttypes.h>
|
|
#include <xfs/libxfs.h>
|
|
#include "init.h"
|
|
|
|
@@ -371,7 +372,7 @@ libxfs_bcompare(struct cache_node *node,
|
|
#ifdef IO_BCOMPARE_CHECK
|
|
if (!(libxfs_bcache->c_flags & CACHE_MISCOMPARE_PURGE)) {
|
|
fprintf(stderr,
|
|
- "%lx: Badness in key lookup (length)\n"
|
|
+ "%p: Badness in key lookup (length)\n"
|
|
"bp=(bno 0x%llx, len %u bytes) key=(bno 0x%llx, len %u bytes)\n",
|
|
pthread_self(),
|
|
(unsigned long long)bp->b_bn, (int)bp->b_bcount,
|