mirror of
https://git.freebsd.org/ports.git
synced 2025-04-29 18:16:48 -04:00
The filesystems category houses file systems and file system utilities. It is added mainly to turn the sysutils/fusefs-* pseudo-category into a proper one, but is also useful for the sundry of other file systems related ports found in the tree. Ports that seem like they belong there are moved to the new category. Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are not moved as they currently don't fetch and don't have TIMESTAMP set in their distinfo, but that is required to be able to push a rename of the port by the pre-receive hook. Approved by: portmgr (rene) Reviewed by: mat Pull Request: https://github.com/freebsd/freebsd-ports/pull/302 PR: 281988
11 lines
358 B
C
11 lines
358 B
C
--- include/xfs_bit.h.orig 2015-07-24 04:28:04 UTC
|
|
+++ include/xfs_bit.h
|
|
@@ -47,7 +47,7 @@ static inline int xfs_highbit32(__uint32
|
|
/* Get high bit set out of 64-bit argument, -1 if none set */
|
|
static inline int xfs_highbit64(__uint64_t v)
|
|
{
|
|
- return fls64(v) - 1;
|
|
+ return flsll(v) - 1;
|
|
}
|
|
|
|
/* Get low bit set out of 32-bit argument, -1 if none set */
|