mirror of
https://git.freebsd.org/ports.git
synced 2025-04-29 01:56:37 -04:00
The filesystems category houses file systems and file system utilities. It is added mainly to turn the sysutils/fusefs-* pseudo-category into a proper one, but is also useful for the sundry of other file systems related ports found in the tree. Ports that seem like they belong there are moved to the new category. Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are not moved as they currently don't fetch and don't have TIMESTAMP set in their distinfo, but that is required to be able to push a rename of the port by the pre-receive hook. Approved by: portmgr (rene) Reviewed by: mat Pull Request: https://github.com/freebsd/freebsd-ports/pull/302 PR: 281988
17 lines
427 B
C
17 lines
427 B
C
--- include/freebsd.h.orig 2015-07-24 04:28:04 UTC
|
|
+++ include/freebsd.h
|
|
@@ -37,10 +37,14 @@
|
|
#define ftruncate64 ftruncate
|
|
#define lseek64 lseek
|
|
#define stat64 stat
|
|
+#define lstat64 lstat
|
|
#define pwrite64 pwrite
|
|
#define pread64 pread
|
|
#define fdatasync fsync
|
|
#define memalign(a,sz) valloc(sz)
|
|
+#define nftw64 nftw
|
|
+#define statvfs64 statvfs
|
|
+#define posix_fadvise64 posix_fadvise
|
|
|
|
#define constpp char * const *
|
|
|