mirror of
https://git.freebsd.org/ports.git
synced 2025-05-01 02:56:39 -04:00
39 lines
997 B
Text
39 lines
997 B
Text
--- src/Makefile.orig 2024-09-29 06:13:21 UTC
|
|
+++ src/Makefile
|
|
@@ -64,7 +64,7 @@ endif
|
|
STD+=-std=c99
|
|
endif
|
|
|
|
-PREFIX?=/usr/local
|
|
+PREFIX:=$(PREFIX)
|
|
INSTALL_BIN=$(PREFIX)/bin
|
|
INSTALL=install
|
|
PKG_CONFIG?=pkg-config
|
|
@@ -128,7 +128,6 @@ FINAL_LIBS=-lm -lstdc++
|
|
FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
|
|
FINAL_LDFLAGS=$(LDFLAGS) $(OPT) $(REDIS_LDFLAGS) $(DEBUG)
|
|
FINAL_LIBS=-lm -lstdc++
|
|
-DEBUG=-g -ggdb
|
|
|
|
# Linux ARM32 needs -latomic at linking time
|
|
ifneq (,$(findstring armv,$(uname_M)))
|
|
@@ -167,6 +166,11 @@ else
|
|
OPENSSL_PREFIX?=/usr/local/opt/openssl
|
|
endif
|
|
else
|
|
+ifeq ($(uname_S),FreeBSD)
|
|
+ # FreeBSD
|
|
+ FINAL_CFLAGS?= $(CFLAGS) $(REDIS_CFLAGS) -I${PREFIX}/include
|
|
+ FINAL_LDFLAGS= $(LDFLAGS) -pthread
|
|
+else
|
|
ifeq ($(uname_S),AIX)
|
|
# AIX
|
|
FINAL_LDFLAGS+= -Wl,-bexpall
|
|
@@ -216,6 +220,7 @@ else
|
|
# All the other OSes (notably Linux)
|
|
FINAL_LDFLAGS+= -rdynamic
|
|
FINAL_LIBS+=-ldl -pthread -lrt
|
|
+endif
|
|
endif
|
|
endif
|
|
endif
|