mirror of
https://git.freebsd.org/ports.git
synced 2025-04-30 18:46:38 -04:00
21 lines
1.2 KiB
Text
21 lines
1.2 KiB
Text
--- deps/Makefile.orig 2023-06-29 16:32:01 UTC
|
|
+++ deps/Makefile
|
|
@@ -83,7 +83,7 @@ LUA_LDFLAGS+= $(LDFLAGS)
|
|
ifeq ($(LUA_DEBUG),yes)
|
|
LUA_CFLAGS+= -O0 -g -DLUA_USE_APICHECK
|
|
else
|
|
- LUA_CFLAGS+= -O2
|
|
+ LUA_CFLAGS+=
|
|
endif
|
|
# lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
|
|
# challenging to cross-compile lua (and redis). These defines make it easier
|
|
@@ -106,7 +106,7 @@ endif
|
|
|
|
jemalloc: .make-prerequisites
|
|
@printf '%b %b\n' $(MAKECOLOR)MAKE$(ENDCOLOR) $(BINCOLOR)$@$(ENDCOLOR)
|
|
- cd jemalloc && ./configure --disable-cxx --with-version=5.3.0-0-g0 --with-lg-quantum=3 --disable-cache-oblivious --with-jemalloc-prefix=je_ CFLAGS="$(JEMALLOC_CFLAGS)" LDFLAGS="$(JEMALLOC_LDFLAGS)" $(JEMALLOC_CONFIGURE_OPTS)
|
|
- cd jemalloc && $(MAKE) lib/libjemalloc.a
|
|
+ cd jemalloc && ./configure --disable-cxx --with-version=5.3.0-0-g0 --with-lg-quantum=3 --disable-cache-oblivious --with-jemalloc-prefix=je_ CFLAGS="$(JEMALLOC_CFLAGS)" CXXFLAGS="$(JEMALLOC_CFLAGS)" LDFLAGS="$(JEMALLOC_LDFLAGS)" $(JEMALLOC_CONFIGURE_OPTS)
|
|
+ cd jemalloc && $(MAKE) CFLAGS="$(JEMALLOC_CFLAGS)" CXXFLAGS="$(JEMALLOC_CFLAGS)" LDFLAGS="$(JEMALLOC_LDFLAGS)" lib/libjemalloc.a
|
|
|
|
.PHONY: jemalloc
|