ports/devel/qscintilla2-qt5/files/patch-Qt4Qt5_qscintilla.pro
Raphael Kubo da Costa 5b3f3dd953 At very long last land PyQt5 5.5.1 ports.
Add the required bits to Uses/pyqt.mk along with all the PyQt5 ports.
Thankfully this commit is mostly adding new ports, as the hard work was
already done in r403297 and r403662.

Huge kudos to Tobias Berner <tcberner@gmail.com> and, most importantly,
Guido Falsi (madpilot@) for their initial work on these ports (see D2910 in
Phabricator for an earlier version of the PyQt5 patch set).

PR:		204672
2015-12-13 21:56:50 +00:00

18 lines
519 B
Prolog

Install the library as libqscintilla2-qt5.so.
The suffix is used to make it differ from libqscintilla2.so, which is the Qt4
version.
--- Qt4Qt5/qscintilla.pro.orig 2015-04-20 14:38:24 UTC
+++ Qt4Qt5/qscintilla.pro
@@ -23,7 +23,11 @@
!win32:VERSION = 12.0.0
TEMPLATE = lib
-TARGET = qscintilla2
+greaterThan(QT_MAJOR_VERSION, 4) {
+ TARGET = qscintilla2-qt$${QT_MAJOR_VERSION}
+} else {
+ TARGET = qscintilla2
+}
CONFIG += qt warn_off release thread exceptions
INCLUDEPATH += . ../include ../lexlib ../src